Příkazy Pro

dokumentace k programu

Sestavy, přehledy

Možnost vytvářet přehledy je samozřejmá vlastnost podobně koncipovaných programů. Zobrazení dat v tabulkové podobě s možností filtrovat a sumarizovat data a je výborný nástroj pro kontrolu a bilancování plateb či inkas. Data je možné exportovat do mnoha formátů, např. MS Excelu a dále s nimi pracovat nebo tisknout či uchovávat jako PDF dokumenty. Formulář pro generování sestav se spustí položkou menu Nástroje | Sestavy, přehledy (viz následující obrázek):

Popis hlavní nabídky

Nabídka Soubor

Export Shift+Ctrl+S - umožňuje exportovat data tabulky. Pokud je aktivovaný filtr, budou exportovaná data omezena tímto filtrem. Vyvolá se nejprve dialog Exportovat data do souboru pro nastavení výstupního formátu souboru, jména souboru a cesty. Podporují se tyto formáty:

Tisk Ctrl+P - spustí tiskový modul, jehož rozhraní umožňuje Náhled na tisk, Export do PDF, přímý Tisk a Editaci předloh tiskové úlohy.

Konec Esc - zavře formulář a zajistí návrat do hlavního formuláře.

Nabídka Úpravy

Hledat Ctrl+F - vyvolá dialog Najít

Po zadání výrazu se spustí vyhledávání kliknutím na tlačítko Najít další. Prohledávají se postupně pole všech sloupečků zleva doprava. Pokud není výraz nalezen, vyhledávání pokračuje vždy na dalším řádku. Proces hledání je přerušen pokud byla nalezena shoda nebo bylo dosaženo konce tabulky.

Hledat další F3 - program si pamatuje naposledy zadané vyhledávací kritérium. Pro další výskyt výrazu není potřeba znovu vyvolávat dialog Najít, je možné aktivovat hledání touto položkou nabídky nebo pohotověji horkou klávesou F3. Jde o zaběhlou konvenci MS Office a obdobných programů.

Nabídka Data

Filtr Alt+F - stiskem tohoto tlačítka se vyvolá vstupní pole pro zadání kritéria filtru.

V rozbalovacím seznamu Kde filtrovat vyberte název sloupečku. Do pole Výraz filtru vložte celý nebo část výrazu. Zátržítko Pouze celé výrazy posuzuje shodnost celého výrazu. Stisknutím tlačítka Filtr se spustí proces během něhož se projdou všechny záznamy a vyhodnotí se. V tabulace zůstanou pouze záznamy vyhovující zadání. Zadané kritérium a počet záznamů, které mu vyhovuje se vypíše ve stavovém řádku.

Zrušit filtr - po stisku tlačítka se zadaný filtr zruší, tím se tabulka naplní všemi záznamy (platbami) bez omezení. Současně se zruší informace o filtrovaných záznamech ve stavovém řádku.

První záznam - navigační tlačítko pro přechod na první záznam (první řádek).

Předchozí záznam - navigační tlačítko pro přechod na předchozí záznam.

Následující záznam - navigační tlačítko pro přechod na následující záznam.

Poslední záznam - navigační tlačítko pro přechod na poslední záznam.

Náhled na základní sestavu

 

Poslední změna dokumentu: 24.03.2017 10:38:27.